Команды для MikroTik CLI

Команды для MikroTik CLI

Коммандная строка MikroTik

На страницах ресурса gotoADM.ru время от времени появляются материалы по настройке оборудования и сервисов на маршрутизаторах и точках доступа фирмы MikroTik. Все настройки выполняются в графическом режиме при подключении к устройству через программу Winbox. Далее указываются требуемые параметры в нужным меню и «все работает». В данной заметке я представляю вашему вниманию альтернативный вариант — подборку команд для работы с консолью (CLI) по соответствующим группам:

Пользователи MikroTik

По умолчанию для входа используется логин admin без пароля. Добавление пользователя:

use add name=имя password=пароль group=full

Отключаемся чтобы зайти под новым пользователем:

quit

Отключение пользователя:

user disable admin

Просмотр пользователей:

user print

 Интерфейсы MikroTik

Просмотр интерфейсов:

interface print

Активация интерфейса:

interface enable 0

Назначение интерфейсу IP адреса:

ip address add address 172.17.1.199/24 interface ether1

Просмотр IP адресов:

ip address print

Изменение MTU интерфейсов:

interface set 0,1,2 mtu=1500

Изменение mac адреса интерфеса:

/interface ethernet set ether1 mac-address=00:01:02:03:04:05

Сброс mac адреса интерфеса:

/interface ethernet reset-mac ether1

Установка шлюза по умолчанию:

ip route add gateway=172.16.1.131

Просмотр маршрутов:

ip route print

Устанавливаем первичный и вторичный адреса DNS серверов:

ip dns set primary-dns=8.8.8.8 secondary-dns=8.8.4.4 allow-remote-requests=yes

Просмотр DNS параметров:

ip dns print

Беспроводные интерфейсы MikroTik

Просмотр беспроводных интерфейсов:

/interface wireless print

Установка времени в MikroTik

Установка часового пояса:

system clock set time-zone=+2

Установка ip адреса ntp сервера с которым будет сверяться время:

system ntp client set enabled=yes primary-ntp=172.16.1.131

Просмотр времени:

/system clock print

Firewall MikroTik

Настройка маскарадинга, чтобы чтобы внутренняя сеть не была видна с WAN порта:

ip firewall nat add chain=srcnat action=masquerade out-interface=интерфейс провайдера

Просмотр правил:

ip firewall filter print

Пример ограничения количества соединений с одного IP:

/ip firewall rule forward add protocol=tcp tcp -options=syn-only connection-limit=5 action=drop

Пример блокировки всех TCP пакетов идущих на порт 135:

/ip firewall rule forward add dst -port=135 protocol=tcp action=drop

Пример проброса портов:

/ip firewall dst-nat add action=nat protocol=tcp dst-address=10.0.0.217/32:80 to-dst-address=192.168.0.4

Системные настройки и информация

Просмотр стандартных настроек:

/system default-configuration print

Сброс настроек:

/system reset-configuration

Просмотр истории:

/system history print

Службы

Просмотр служб:

/ip service print

Прочая информация по коммандрой строке MikroTik

Переход на уровень выше:

/

Выполнение команды из другого уровня без смены текущего:

/.

Помощь:

?

Настройка маршрутизатора с помощью мастера настроек:

setup

Пинг:

ping 192.168.1.2 count 3 size 512

Вход и выход из безопасного режима: Ctrl+X. Мини шпаргалка или памятка по командам для консоли маршрутизаторов MikroTik готова и будет обновляться. Какие комманды используете вы?